Oblivion CS:Main menu

Материал из Tiarum
Перейти к: навигация, поиск


TES 4 CS : Главное меню

TES 4: Construction Set - это великолепный редактор для игр серии The Elder Scrolls. С его помощью вы можете вносить изменения в игру The Elder Scrolls IV: Oblivion. Абсолютно все, что есть в игре, было добавлено в неё с помощью этого редактора и хранится в файлах с расширениями ESM, ESP и в архивном файле BSA.

Чтобы начать работу с конструктором, сначала скачайте его новую версию с официального сайта: TES CONSTRUCTION SET v1.2.404

Новый патч v1.2 к игре вы также можете скачать на официальном сайте: SHIVERING ISLES PATCH v1.2.0416

Если вы плохо знаете английский, установите русификатор. Описывая меню конструктора, мы будем приводить в скобках русские названия диалоговых окон, соответствующие таковым в русифицированном варианте конструктора. Запустите конструктор и давайте разберемся с интерфейсом. В верхней части находится главное меню, под которым расположена панель инструментов. На панели находятся иконки, которые отвечают за все главные операции и очень удобны для манипуляций с игровым миром. Иконки дублируют пункты главного меню.

Oblivion Main menu.jpg

Под ними находится главное рабочее окно, в котором размещены следующие диалоговые окна:

  • Render Window (Окно рендеринга) - окно для просмотра, создания и редактирования 3d-сцен в игровых локациях.
  • Object Window (Окно объектов) - его условно можно разделить на две составляющие — левую и правую. Левая часть представляет собой длинный список категорий объектов в виде ветвящегося дерева и по структуре напоминает окно проводника Windows. Если выделить конкретную категорию, то в правой части можно просмотреть, какие объекты ей соответствуют. Выбрав пункт World Object, например, а затем Static, вы увидите в правой части окна полный список всех неподвижных объектов.
  • Cell View (Просмотр локаций) - окно выбора ячеек, в котором находится список всех локаций, составленный в виде таблицы. В окне содержатся как внутренные ячейки – интерьеры, так и внешние - экстерьеры.

Перечень локаций находится слева. В правой части для выбранной конкретной локации отображаются все ресурсы, находящиеся в ней – NPC, статические объекты, существа, контейнеры и пр.

TES 4 CS : Пункты главного меню

TES 4 CS : Полная структура главного меню

Ниже приведено полное дерево главного меню с ссылками на соответствующие страницы


Меню File – Файл

  • Data… (Данные) - Диалоговое окно Data (Открыть данные)
  • Save (Сохранить) - Диалоговое окно Select File (Выбрать файл)
  • Export ► (Експорт)
    • Interior and Exterior Cell Data (Данные внутренних и внешних ячеек)
    • Form Component Data for all non-Worlds Form (Сформировать компоненты данных для всех немировых форм)
    • Dialogue (Диалоги)
    • Quest Stages (Стадии квеста)
    • Names (Наименования)
    • Script Messageboxes (Скриптовые функции Messagebox)
    • GameSettings (Игровые настройки)
    • Books (Книги)
    • Descriptions (Описания)
    • Faction Rank Names (Названия рангов фракций)
  • Import ► (Импорт)
    • Dialogue (Диалоги)
    • Quest Stages (Стадии квеста)
    • Names (Наименования)
    • Script Messageboxes (Скриптовые функции Messagebox)
    • GameSettings (Игровые установки)
    • Books (Книги)
    • Descriptions (Описания)
    • Faction Rank Names (Названия рангов фракций)
  • Preferences - (Предпочтения) - Диалоговое окно Preferences (Предпочтения)

---

  • Exit (Выход)


Меню Edit – Правка

  • Undo (Отменить) Ctrl+Z
  • Redo (Повторить) Ctrl+Y

---

  • Cut Render (Вырезать) Ctrl+X
  • Copy Render (Копировать) Ctrl+C
  • Paste Render (Вставить) Ctrl+V
  • Paste in place (Вставить на место) Ctrl+Shift+V
  • Dublicate (Дублировать) Ctrl+D

---

  • Find (Найти) - Ctrl+F - Диалоговое окно Find (Найти)
  • Find Next (Найти следующее) F3
  • Find Prev (Найти предыдущее) F2
  • Find Text (Найти текст) - Диалоговое окно Text Search (Поиск текста)
  • Search & Replace… (Найти и заменить) - Диалоговое окно Search & Replace (Поиск и замена)

Меню View – Вид

  • Toolbar (Панель инструментов)
  • Statusbar (Строка состояния)
  • Render Window (Окно рендеринга)
  • Object Window (Окно объектов)
  • Cell View Window (Окно просмотра ячеек)
  • Open Windows (Открыть окна) - Диалоговое окно Open Windows (Открыть окна)

---

  • Current Cell Only (Только текущая ячейка)

---

  • Markers (Маркеры) M
  • Light Radius (Радиус света) L
  • Wireframe (Каркас) W
  • Bright Light (Яркость света) A
  • Sky (Небо) Y
  • Solid SubSpaces (Материальные подпространства)
  • Collision Geometry (Геометрические коллизии) F4
  • Leaves (Листва) V
  • Trees (Деревья)

---

  • Isometric (Изометрия) C
  • Top (Вид сверху) T


Меню World – Мир

  • Weather (Погода) - Диалоговое окно Weather: xxxx (Погода: )
  • Climates (Климат) - Диалоговое окно Climates: xxxx (Климат: )
  • World Spaces (Игровое пространство мира) - Диалоговое окно World Space: xxxx (Игровое пространство мира)
  • Regions (Регионы) - Диалоговое окно Region Editor (Редактор регионов)
  • Cells (Ячейки) - Диалоговое окно Cell (Ячейка)

---

  • World Testing ► (Тестирование мира)
    • Test Models (Тестирование моделей)
    • Test Icons/Textures (Тестирование иконок/текстур)
    • Test All Cells (Тестирование всех ячеек)
    • Test Interior Cells (Тестирование внутренних ячеек)
    • Test Path Beetween Cells (Тестирование путей между ячейками)
    • Output Model Size List (Вывести список моделей)
    • PathGrids ► (Сетки путей)
      • Test PathGrids (Тестировать сетки путей)
      • Fix Interior PathGrids (Исправить сетки путей интерьеров)
      • Fix Exterior PathGrids (Исправить сетки путей внешних ячеек)

---

  • Update Distant LOD Data (Обновить данные о дистанции LOD)
  • Update Bounds and Textures (Обновить границы и текстуры)
  • Recalc Land Normal (Пересчитать нормали ландшафта)

---

  • Edit Cell Path Grid (Редактировать сетки путей ячеек)
  • Path Grid Generation ► (Генерация сетки путей)
    • Generate Active Cell (Сгенерировать в активной ячейке)
    • Generate Selected Cells (Сгенерировать в выбранной ячейке)
    • Generate All But Selected Cells (Сгенерировать все, но в выбранные ячейки)
    • Generate Entire Cell (Сгенерировать во все ячейки)
    • ---
    • Remove from Active Cell (Удалить из активной ячейки)
    • Remove from Selected Cells (Удалить из выбранной ячейки)
    • Remove from All But Selected Cells (Удалить все, но из выбранных ячейках )
    • Remove from Entire Cell (Удалить из всех ячеек)

---

  • Run Havok Sim (Запустить физический движок Havok)

---

  • Landscape editing (Редактирование ландшафта) - H - Диалоговое окно Landscape Edit * Settings (Редактирование настроек ландшафта)
  • Heightmap Editing (Редактирование карты высот) - Диалоговое окно Select WorldSpace (Выбрать игровое пространство)

---

  • Create Local Maps (Создать локальную карту) - Диалоговое окно Local Map Creation (Создание локальной карты)


Меню Character – Персонажи

  • Hair (Волосы) - Диалоговое окно Hair (Волосы)
  • Eyes (Глаза) - Диалоговое окно Eyes: xxxx (Глаза: )

---

  • Race (Раса) - Диалоговое окно Race: xxxx (Раса: )
  • Skills (Умения) - Диалоговое окно Skill: xxxx (Умения: )
  • Class (Класс) - Диалоговое окно Class (Класс)
  • Birthsigns (Знак рождения) - Диалоговое окно Birthsigns (Знак рождения)

---

  • Factions (Фракции) - Диалоговое окно Faction: xxxx (Фракция: )

---

  • Packages (Пакеты) Диалоговое окно AI Packages (AI-пакеты )
  • Quests (Квесты) Диалоговое окно Quests (Квесты)
  • Filtered Dialogue (Фильтры диалога) - Диалоговое окно Dialogue (Диалоги)

---

  • Export Dialogue (Экспорт диалога) - Диалоговое окно Export Dialogue (Экспорт диалога)
  • Export NPC Face Textures (Экспорт текстур лица NPC) - Диалоговое окно Confirm (Подтверждение)


Меню GamePlay – Геймплей

  • Magic Effects (Магические эффекты) - Диалоговое окно Magic Effect (Магические эффекты)

---

  • Settings (Настройки) - Диалоговое окно Game Setting: xxxx (Игровые настройки)

---

  • Edit Scripts (Редактор скриптов) - Диалоговое окно Script Edit (Редактор скриптов)
  • Globals (Глобальные переменные) - Диалоговое окно Global: xxxx (Глобальные переменные)

---

  • Idle Animations (Неактивная анимация) - Диалоговое окно Idle Animations (Неактивная анимация)
  • Facial Animation (Анимация лица) - Диалоговое окно Facial Animation (Анимация лица)


Меню Help – Помощь

---

  • About (О программе) - Логотип-заставка "About TES Construction Set"