Morrowind CS:Menu Data Files

Материал из Tiarum
Перейти к: навигация, поиск


TES 3 CS => Menu => File => Data Files... (Файлы данных)

TES3 Menu File DataFiles.jpg


Подменю File => "Data Files..." (Файлы данных) используется для выбора исходных файлов данных для просмотра, редактирования существующего плагина или создания нового. В конструктор могут быть загружены одновременно несколько мастер-файлов в формате *.esm и несколько плагинов с расширением *.esp.

При активации данного пункта Data Files... открывается диалоговое окно с одноименным названием - Data Files:


TES3 Menu Window DataFiles.jpg


В окне доступны следующие поля и кнопки:

  • Таблица "TES Files" (Файлы TES)
  • Поле "Created by" (Автор)
  • Текстовое поле "Summary" (Краткое описание)
  • Информационное поле "Parent Masters" (Мастер-файлы)
  • Текстовые строки с информацией о файле, на котором в данный момент находится "фокус":
  • "Created On" (Дата создания файла)
  • "Last Modified" (Дата последней модификации файла)
  • "File Version" (Версия файла при создании)
  • "Current" (Текущая версия файла)
  • Кнопки:
  • "Set as Active File" (Отметить как активный файл)
  • "Details..." (Детали...)
  • "OK" (подтвердить)
  • "Cancel" (отменить)


Описание полей диалогового окна Data Files

Таблица "TES Files" (Файлы TES)


Таблица "TES Files" находится в левой верхней части окна.

В таблице имеется две колонки:

  • "TES3Files"
  • "Status"

В первой приведены все мастер-файлы с расширением *.esm и все файлы плагинов с расширением *.esp, которые были обнаружены в директории с установленной игрой (...Morrowind/Data Files).

Во второй колонке отображается текущий статус файла. Он может иметь всего три значения:

  • Master File
  • Plugin File
  • Active File

Для того, чтобы файл загрузился в конструктор и его содержание стало доступным для дальнейшего редактирования, щелкните по строке с его названием двойным щелчком левой кнопки мыши.

Если отметить только файл плагина, то в конструктор загрузятся также и мастер-файлы, которые были загружены в момент его последнего сохранения и ресурсы которых он использовал.


Кнопка "Set as Active File" («Отметить как активный файл»)


Позволяет отметить плагин как активный. Пометка Active File означает, что все изменения, которые будут сделаны в сеансе работы в конструкторе, сохранятся именно в отмеченном плагине.

  • Если щелкнуть левой кнопкой мыши на одном из файлов плагина в таблице "TES Files", а затем нажать на кнопку "Set as Active File" («Отметить как активный файл»), то напротив него в боксе появится галочка (крестик), а в поле "Status" появится пометка - Active File.
  • Отметить плагин как "активный" можно также двойным щелчком правой кнопки мыши на строке с его названием в таблице "TES Files".
  • Отметить как "активный" можно только один плагин.
  • Сделать активным мастер-файл не удастся. Это является положительным моментом, так как в этом случае пользователь никоим образом (разве что с помощью вспомогательных утилит) не сможет изменить исходный мастер-файл.


Кнопка Details... («Детали»)


  • Нажатие на кнопку Details... («Детали») выдает список игровых объектов, которые изменяет (с которыми взаимодействует) данный плагин.


TES3 Menu File DataFiles FileDetails.jpg

  • На иллюстрации выше видно, что в плагине Animation Idiot.esp изменений основной игры немного - всего 4 строки.
  • Данное меню можно использовать для очистки плагина от "мусора".
На иллюстрации одна строка вызвала сомнение у автора. Это "NPC_" - "a shady smuggler".
Плагин Animation Idiot.esp носит демонстрационный характер и написан для руководства "Анимация Motion Capture в игре TES 3: Morrowind". Поэтому можно сделать вывод, что эта строка - просто "мусор", который возник случайно.


Поле "Created by" («Автор»)


  • В поле «Автор»(Created by) обычно указывается имя автора и/или адаптатора плагина.


Поле "Summary" («Описание»)


  • В поле "Summary" («Описание») обычно даётся краткое описание плагина. Обратите внимание, что для сохранения изменений в этом тексте сохранять или даже загружать плагин не нужно.
  • Поле доступно для редактирования. На этапе создания в этом поле автор может делать рабочие пометки, а в конечном плагине - разместить его краткое описание.


Поле "Parent masters" («Мастер-файлы»)


  • В поле "Parent masters" («Мастер-файлы») указаны мастер-файлы (для Морровинда, Трибунала или БладМуна) или другие плагины, необходимые для работы с этим плагином и которые были загружены в момент последнего сохранения.


Кнопка "Cancel" («Отмена»)


  • Эта кнопка позволяет отменить все действия, которые были сделаны в данном диалоговом окне и закрыть окно.


Кнопка "ОК" («Подтвердить»)


  • Все отмеченные файлы будут загружены в конструктор после нажатия на кнопку «ОК».
  • Если активный файл не указан, то перед загрузкой файлов на экран будет выведено предупреждающее окошко "Active File Warning" с сообщением:

"You have not set a file as the active file. Do you wish to continue?" - "Вы не отметили файл как активный. Вы хотите продолжить?"


TES3 Menu File Load ActiveFileWarning.jpg


Смотрите также: