Morrowind:Искусство адаптации

Материал из Tiarum
Перейти к: навигация, поиск
TES III: Morrowind: Искусство адаптации
45px-Scroll.png

автор: Menorra
редактор: Владимир, Garin
ccылка на оригинал: "Перевод плагинов для Morrowind. Подробное руководство."
дата публикации оригинала: 13.4.2008г.
ссылка на сайт: Fullrest.ru
ver: 1.4

Авторская Эта страница защищена авторскими правами..
Не редактируйте его без предварительного согласования с автором! Свои изменения и дополнения вы можете предложить непосредственно автору, либо на Форуме, либо на странице Обсуждения


TES III: Morrowind: Искусство адаптации



Многие, поиграв в Морроувинд, начинают всячески украшать игру разнообразными плагинами, добавляющими доспехи \ оружие \ одежду \ животных \ неписей \ расы \ квесты \ возможности etc., заменяющими стандартные неказистые модели и размытые текстуры и так далее. Но часто невозможно найти в русском варианте то, чего именно вам не хватает для полного счастья. Тогда приходится играть в английские версии, что в сочетании с локализованной игрой смотрится очень криво. Для устранения подобных проблем и существуют адаптаторы.


Здесь я попытаюсь как можно подробней описать процесс адаптирования плагинов с помощью прилагающейся к игре программы – TES Construction Set (русской версией не пользуйтесь никогда - она работает с ошибками).


Обратите внимание: многие плагины требуют установленные официальные дополнения – Bloodmoon и Tribunal, без них они работать не будут.

TES III: Morrowind
TES III: Tribunal
TES III: Bloodmoon


Также я расскажу, как привести некоторые детали в порядок, ведь задача адаптатора не только перевести текст, но и сделать всё, чтобы нашему игроку было удобно пользоваться плагином.



Самое необходимое

Что же требуется в наипервейшую очередь для того, чтобы стать адаптатором? А вот что:

MAA 005.jpg
  1. Установленный лицензионный Morrowind с официальными дополнениями - Bloodmoon и Tribunal (вам нужна лицензия и только лицензия, пиратские версии настолько криво сделаны, что практически все плагины с ними будут конфликтовать и вызывать разнообразные ошибки, а сделанные под пиратки адаптации не будут рассматриваться ни одним порядочным сайтом).
  2. Очень хорошее владение русским языком, умение писать без ошибок (орфографических, синтаксических, пунктуационных и т.д.), албани и прочей ереси.
  3. Знание английского языка на достойном уровне, возможность работы с текстами на нем.
  4. Англо-русский словарь. Настоятельно рекомендую скачать последнюю версию Lingvo. Если уж совсем-совсем никак, то здесь вы найдёте его версию on-line.
  5. Знание TES Lore (истории и терминологии мира Древних Свитков).
  6. Ну и, конечно же, желание освоить все премудрости сего искусства и начать радовать рядовых юзеров хорошими адаптациями хороших плагинов.



Программы и утилиты

Для создания качественной адаптации (ведь другой нам и не надо) понадобятся следующие утилиты (все их можно скачать в разделе "Программы" базы FullRest):


MAA 012.JPG BSAPack и BSAReg


  • BSAReg нужен для регистрации игровых архивов, т.е. файлов .bsa в Morrowind.ini. Помещаем файл в \Morrowind\Data Files. Теперь, если установленный плагин имеет при себе архив .bsa, открываем \Morrowind\Data Files\BSAReg.exe. В нём 2 поля: в левом отображаются ещё не зарегистрированные архивы, в правом - ранее зарегистрированные, но теперь удалённые. Нажимаем Update, нужное прописывается, ненужное удаляется. Теперь требующий данный архив плагин будет работать корректно.


Список нуждающихся в регистрации или удалении архивов


Если незарегистрированных архивов нет, то вместо окошка с двумя полями появится другое окошко с текстом "All BSA arcives are already properly registred". Просто нажимаем OK.


Уведомление о том, что все архивы .bsa зарегистрированы


Обратите внимание: многие, кто связан с моддингом, ставят две и более копий игры - одна с плагинами для игры и красивых скриншотов, вторая - чистая для тестирования, перевода и разработки. Так вот, в таком случае вам нужно будет запускать BSAReg не с BSAReg.exe, а с BSAReg.bat (он есть в архиве к программе только на Fullrest.ru), иначе программа не будет работать. Также программу нужно запускать с bat-файла в случае, если вы вручную переносили игру из папки, куда она была установлена, или если вы переустанавливали систему, а игру нет.


  • BSAPack нужен для упаковки файлов плагина в архив с тем, чтобы в случае чего пользователь мог его легко удалить. Об этом позже.

MAAA 011.JPG Mod Prepare


Утилита для конвертирования между ESP <-> ESM <-> ESS (файл сохранения), удаления зависимости от мастер-файлов и изменения диалогов плагина для редактирования в конструкторе (разговорное название TES Construction Set).

Потребность конвертировать мастер-файл в файл плагина возникает крайне редко, так что с этой опцией со временем познакомитесь самостоятельно.

Диалоги

Изменение диалогов плагина для редактирования в конструкторе: помните в игре синие ссылки на темы в речи NPC?


Так выглядят ссылки на темы в игре


В конструкторе слово—ссылка выделяется символами "@" и "#". Например, @дам совет# - если кто-то вам скажет фразу, содержащую такое словосочетание, то оно превратится в нажимаемую ссылку.


Так выглядят ссылки на темы в конструкторе


Конструктор, по-видимому, из-за ошибки, допущенной разработчиками, эти символы в диалогах, добавляемых плагинами, не отображает (в стандартных диалогах игры символы видны). Но даже если в конструкторе их нет - ничего страшного, они всё равно будут в игре отображаться как ссылки, единственное что - вы можете не заметить ссылку и перевести её как-то иначе, чем топик, на который она ссылалась. Кнопка Update Hyperlinks (в окне диалогов справа) расставляет @ и # всем ссылкам в текущем ответе топика.


Обрабатывать надо ТОЛЬКО плагины, которые добавляют ответы в стандартные топики игры, и в этих ответах есть ссылки на тоже стандартные топики игры.


Поэтому перед тем, как начать переводить плагин с большим количеством диалогов, устанавливаем программку в папку с игрой и запускаем её:

  • В верхней части окошка видим длинную кнопку «Выберите файл». Нажимаем её и выбираем нужный нам плагин.
  • Под заголовком «Подготовить диалоги» выбираем «Подготовить для редактирования», всё остальное оставляем как есть.
  • Внизу жмём «Запустить». Программка спросит, как назвать и куда сохранить заново полученный файл. Я обычно сохраняю поверх того же файла. Капитально ничего не изменилось, просто все @ и # в начале и конце слова (словосочетания)-ссылки изменились на { и }, так что теперь в конструкторе распознать ссылки стало проще (наш {дам совет} теперь в фигурных скобках).
  • Теперь можно спокойно редактировать диалоги и правильно обозначать ссылки.
  • Когда вы закончили с конструктором, сохраняем результат и проделываем вышеописанную операцию ещё раз, но теперь уже выбрав «Подготовить для игры».
  • Следите за тем, чтобы в названии конечного файла не было приставок EDIT_ и GAME_ - это приставки, которые программка предлагает подставить к изначальному названию плагина.


1


2

MAA 013.JPG TES Advanced Mod Editor


Эта простая программа предназначена для чистки плагинов от лишнего мусора. Также позволяет объединять два плагина в один.

Бывает так, что авторы плагинов во время разработки (или адаптаторы во время адаптации) задевают стандартные предметы и ячейки. Это лишняя информация, которая запишется в файл плагина, и может вызвать ошибки.

Удалять что-либо через конструктор не вполне удобно и делать этого не стоит. А посему нам и понадобится эта программа.

MAA 014.JPG TES Plugin Conflict Detector


Эта программа предназачена для поиска конфликтов между плагинами. Умеет выводить список одинаковых обьектов в плагинах, удаленные обьекты, невычищенные записи, список обьектов плагина и изменений оригинальных обьектов игры. Также позволяет сразу и отредактировать или удалить любой из показанных обьектов. Нам она поможет в выявлении задетых объектов, которые не нужны для работы плагина и являются мусором.


MAA 015.JPG Woody Texture Viewer


Отличный просмотрщик DDS-файлов, умеет показывать прозрачность, формат сохранения изображения, мип-уровни, размеры и прочее.

Вы можете проассоциировать .dds файлы с WTV, чтобы сразу быстро просматривать их. Для этого открываем WTV.exe, в меню выбираем Help, затем выбираем Associate DDS files with WTV.


MAA 016.JPG Adobe Photoshop


Не пугайтесь, если не умеете в нём работать - мы ничего сверхсложного делать там не будем. Он понадобится только для того, чтобы конвертировать текстуры. Открыл, сохранил с нужными параметрами, вышел. 3 клика. А нужен нам этот страшный сложный Фотошоп, а не DDS Converter или какая-нибудь другая программа, которая специально создана для наших целей, потому, что при работе в них теряется исходное качество текстуры - становится хуже. А в Photoshop этого не происходит. Нам для этой цели подойдёт абсолютно любая, самая обрезанная и ужатая версия программы.

MAA 16.JPG NifSkope


NifSkope - программка, с помощью которой можно просматривать модели (.nif) и анимации. Для работы с моделями Морровинда нам понадобится версия 0.8.5, более поздние больше ориентированы на работу с моделями Обливиона и с моделями Морровинда могут работать некорректно. О том, зачем она нам понадобится, в разделе про архивы BSA.

MAA 017.JPG Mod Info


Mod Info - утилита для просмотра содержимого плагинов к Morrowind, экспорта данных и генерации различных отчетов. Понадобится она нам в случае, если мы переводим плагин, как-либо изменяющий стандартные объекты игры.


MAA 018.JPG Mod Text Merger


Утилита Mod Text Merger предназначена для замены текста в некоторых типах записей в плагинах Morrowind. В основном применяется для импортирования перевода обратно в плагин. Понадобится нам вместе с Mod Info. О применении этих двух утилит немного позже.


Не забывайте читать прилагающиеся к архивам как русские, так и оригинальные ридми!

Полезные ресурсы

MAA 004.gif


Наиболее крупные зарубежные базы плагинов:

  • Morrowind Nexus - крупная, хорошо организованная база плагинов к Морровинду.
  • Morrowind Modding History – ранее тут в основном находили последнее пристанище самые старенькие плагины, которые больше нигде не найдёшь. Однако в связи с прекращением работы Elric Melnibone and The Elder Scrolls и гиганта Planet Elder Scrolls сюда стали заливаться и новые файлы, а также те, что были на означенных почивших ресурсах.
  • Great House FLiggerty - здесь также, помимо прочих, стоит искать плагины, ушедшие вместе с Elric Melnibone and The Elder Scrolls и Planet Elder Scrolls.


Это 3 основных источника. Если же для вас там ничего не нашлось, не стесняйтесь спрашивать у всесильного Гугла

Если у вас возникнут какие-либо вопросы по Lore, поищите ответы зедсь:


Итак, терпением запаслись, прикладные утилиты скачали и ознакомились, плагин выбрали, теперь можно приступать к собственно переводу.

Процесс перевода

  • Помещаем все файлы плагина, который нам предстоит переводить, в папку ...\Morrowind\Data Files.
  • Заходим в папку с игрой и открываем TES Construction Set.
  • Вверху, в меню File, нажимаем Data Files (или значок MAA 019.JPG). Выпадает окошко со списком установленных дополнений и плагинов. Они есть двух типов: master file и plugin file (в расширении файла мастер - .esm, плагин – .esp). Мастер-файлы, такие как Morrowind.esm, изменять нельзя и от них зависит работоспособность плагинов. Здесь же, если вы всё правильно установили, мы видим наш плагин (допустим Something_new.esp).
  • Справа мы видим поле с именем автора (Created By). Не будем скромничать и допишем : / лок. Ваше Имя . (лок. - это локализатор – то же самое, что и адаптатор, но в узнаваемом сокращении занимает меньше символов).
  • Здесь же мы видим окошко с описанием плагина – заголовок (Summary). Здесь не обязательно дословно переводить то, что вписал автор, а нужно краткое описание плагина – что добавляет и где найти \ как начать квест etc. Главное – информативность. Вмещает заголовок 258 символов.
  • Далее ставим галочку напротив нашего плагина, дважды кликнув на квадратик возле него в окошке TES Files (если она не ставится, значит у вас не установлены нужные ему мастер-файлы? их вы можете видеть в окошке справа - Parent Masters), нажимаем кнопку ”Set as Active File” (это значит, что мы собираемся редактировать плагин, а не просто посмотреть) и далее – «ОK».


Информация о плагинах


Пока мы не начали перевод, хочу предупредить: буква "ё" в игре отображаться не будет, поэтому вместо неё пользуйтесь "е"!


Окно объектов Object Window


Слева мы видим окно ”Object Window”, а в нём - кучу вкладок. Здесь нам предстоит переводить названия всяких объектов. Окошко разделено на столбики, нас интересуют три:

  • ID (сокращенное identification - идентификация): это имя, по которому игра опознаёт предмет. Его ни в коем случае не трогаем!
  • Name – имя предмета. Его нам переводить и надо.
  • Count – количество предметов в игре.

Изменённые или добавленные плагином предметы выделяются звёздочкой (*) в столбце ”Count”.

Вкладки:


  • Activator – здесь находятся все предметы, которые нельзя взять, но если на них навести курсор, ты выплывет их название. Например, вывески перед тавернами, магазинами и городами.
  • Alchemy – зелья и спиртные напитки.
  • Apparatus – алхимические приборы: кальцинаторы, перегонные кубы, реторты и ступки с пестиками.
  • Armor - доспехи: шлемы, щиты, наплечники и т.п.
  • Body Part – части тел неписей. Нам это не трогать нужно.
  • Book – книги. Текст книг будет находиться в правой половине окошка Edit. Переводим весь текст, не трогая тэгов (<br>, <DIV ALIGN="LEFT"> и т.п.). Можно его полностью скопировать в Word и переводить там, опять-таки, не задевая тэгов.
  • Clothing – одежда, кольца, пояса и т.п.
  • Container – контейнеры: бочки, сундуки, а также растения (они тоже считаются контейнерами).
  • Creature – существа (алиты, скрибы, скелеты, рьеклинги etc.).
  • Door – двери.
  • Enchanting – эффекты зачарования. Нам не нужно.
  • Ingredient – алхимические ингредиенты.
  • Leveled Creature – существа, которые начинают появляться в зависимости от уровня персонажа. Не трогаем.
  • Leveled Item – предметы, появляющиеся где-либо в зависимости от уровня персонажа. Нам не нужно.
  • Lights – источники света. Большинство из них не имеет названий и в игре их сложно заметить – это просто место, которое излучает свет. Имеющие название источники света – факела, свечи, фонари и лампы.
  • Lockpick – отмычки.
  • Misc Item – всё, что не вписалось в другие категории (разнообразная посуда, ключи, золото etc.).
  • NPC – Non-Playable Characters, в разговорной речи – неписи – люди, с которыми наш персонаж взаимодействует.
  • Probe – щупы.
  • Repair Item – молотки и клещи.
  • Spellmaking – заклинания, которыми может пользоваться игрок или непись.
  • Static – разнообразные статичные предметы (ковры, камни, части зданий etc.). Не трогаем.
  • Weapon – оружие.


Вкладки


Чтобы найти добавленные предметы, отсортируйте их по названию (кликнув левой кнопкой мышки на заголовок столбика ”Name”), все предметы с английскими названиями появятся в самом верху. C этим окошком закончили.

Ячейки (окно Cell View)


Справа снизу находится окошко ”Cell View”.

В левой части окошка перечислены все ячейки с координатами (Grid) – все места на карте, в которых может побывать персонаж. Изменённые или добавленные ячейки также отмечаются звёздочками в столбике Grid. Все стандартные ячейки имеют английские названия (за исключением Пустошей, всех Районов и некоторых ячеек Солстхейма). Их мы ни в коем случае не трогаем!. А вот названия добавленных плагином ячеек переводить обязательно. Для этого выделите ячейку, кликнув на неё левой кнопкой мышки, и нажмите F2, либо же через секунду снова нажмите левой кнопкой.

В правой части окошка ID, тип и владелец всех предметов, находящиеся в данной ячейке. Изменённые или добавленные отмечаются звёздочками в столбике ”Object ID”. Если ячейка отмечена как изменённая, а отмеченных звёздочкой предметов в ней нет, значит она наверняка задета случайно и её нужно удалить, дабы не засорять плагин (см. инструкцию к TESame в начале статьи).


Окно с информацией о всех ячейках


Просмотрщик (окно Render Window)


Справа сверху мы видим окошко ”Render Window”. Это окно для просмотра. Нам оно не очень нужно. Если вы всё же хотите посмотреть на ячейку, дважды кликните по ней левой кнопкой мышки, а если предмет – правой кнопкой -> Info, двойной щелчок на ячейку, в которой предмет находится. Здесь же можно перемещать предметы. Но лучше этого не делать. Если вы хоть слегка переместите предмет в незадетой ячейке, то она моментально станет таковой, а это лишний мусор.


Окно просмотра


С материальными предметами мы разобрались. Далее мы переходим в верхние меню и смотрим, что же там может нас заинтересовать.


Меню Character и Gameplay



Character


Gameplay


  • Меню Character -> Race – в нем находятся имеющиеся в игре расы, их свойства и описания. В выпадающем окошке ID смотрим, нет ли новой расы. Если есть, в поле Name переводим её название. В правой нижней части есть поле Description, в нём должно быть описание расы, которое мы видим при создании персонажа. Переводим. С этим пунктом всё. Жмём «ОК».


Меню информации о расах


  • Меню Character -> Skills – навыки (акробатика, тяжёлые доспехи etc.). Сюда что-то добавляется очень и очень редко. Но всё же: здесь в поле Description можно перевести описание, а вот название - в Gameplay -> Settings на вкладке Stats.


Описания навыков


Названия навыков


  • Меню Character -> Class – классы. Как играбельные (Меч Ночи, Монах etc.), так и классы неписей (Обыватель, Трактирщик, Торговец etc.). Слева сверху в поле Name переводим название класса, в поле Description – описание (даже если класс не играбельный!).


Меню информации о классах


  • Меню Character -> Birthsigns – знаки зодиака. В меню ID выбираем знак, в поле Full Name переводим его название, ниже, в поле Description переводим описание знака (стараемся, чтобы оно как можно больше походило на описания оригинальных знаков, например «Созвездие Башни с первичным Аспектом Секунды.»).
Меню информации о знаках зодиака
  • Меню Character -> Faction – фракции (гильдии), опять-таки, как играбельные (Гильдия Магов, Великий Дом Редоран etc.), так и не играбельные, в которых состоят неписи (Камонна Тонг, Культ Талоса, Восточная Имперская Кампания etc.). Сверху напротив ID фракции опять-таки в поле Name переводим её название.


Меню информации о фракциях


  • Меню Gameplay -> Magic Effects – базовые эффекты, на основе которых сделаны заклинания и зачарования. Здесь, как и в Skills, очень редко что-то появляется, в основном, по ошибке задевается старое. Если так, то TESame нам в помощь. Если же это сознательное добавление, здесь мы переводим описание в уже знакомом поле Description, название эффекта в Gameplay -> Settings на вкладке Magic.


Описания магических эффектов


Названия магических эффектов

Скрипты


Меню Gameplay -> Edit Scripts или кнопка OAGB 07.png – скрипты, отвечающие за работу тех или иных функций в игре (например, спит персонаж с помощью скрипта, кольца перемещения работают тоже с помощью скриптов). Здесь следует быть очень аккуратным и не задеть ничего, что не относится к переводу, иначе, в лучшем случае, то, на чём висит скрипт, не будет правильно работать, в худшем – игра не будет даже грузиться.


Итак: в окошке ”Script Edit” открываем меню Script -> Open (кнопка OAGB 01.png).

Открывается окошко ”Script Pick”. Изменённые скрипты тоже отмечаются звёздочками в конце названия. Название переводить не надо, да и не получится.


Список скриптов


Находим нужный скрипт, дважды кликаем по нему левой кнопкой мышки. Теперь он доступен для редактирования.

Если в начале строчки стоит точка с запятой (;), то всё, что находится после неё, на работу скрипта никак не влияет и переводить его не надо.


Текст после точки с запятой


Нас интересует следующее:

  • Фразы в кавычках после слов MessageBox и Say. Если в слове присутствует символ "%" или что-то подобное, не удаляйте его! Например: «До окончания работ осталось %.Of дней». %.Of - это значение, которое с течением времени меняется (5 дней, 4 дня и т.д.).


MessageBox, Say, %.Of - переменное значение


  • Фразы в кавычках после AddTopic. О топиках я расскажу далее, в разделе про диалоги. Сейчас просто запомните, что переводить нужно буква в букву с самим названием темы (топика). Если топик с большой буквы – здесь тоже с большой, если с точкой в конце, значит с точкой, если топик – «мыши», то тут тоже «мыши», а не «мышь».


AddTopic


  • Названия ячеек в кавычках после CenterOnCell, GetPCCell, PlaceItemCell, PositionCell и им подобных. Допустим, есть у нас GetPCCell ”Our New Home” - ячейка не стандартная, значит, переводим её в точности так же, как перевели в окошке Cell View - GetPCCell ”Наш Новый Дом” (названия стандартных ячеек оставляем на английском - как в Cell View!). С названиями отдельных ячеек регионов всё несколько иначе: если мы видим название ячейки типа West Gash Region , 4, -19 (координаты указывают на то, что это отдельная ячейка, а не название региона!), то, несмотря на то, что название стандартное, переводим его на русский точно так же, как оно переведено опять-таки в окошке Cell ViewРайон Западного Нагорья.


Связанные с ячейками команды


  • ChangeWeather. Тут всё немного иначе. Названия регионов здесь нужно оставлять английскими - в соответствии с их ID, которые можно увидеть в World -> Regions, а не с названием.


ChangeWeather


ID регионов


  • ShowMap "Zainab Camp" – в такой записи любая ячейка должна выглядеть точно так же, как в окне Cell View.


ShowMap


Каждый раз перед тем, как перевести название какой-либо ячейки, обязательно сверяемся с окошком Cell View!

Когда скрипт переведён, нажимаем меню Script -> Save или OAGB 03.png. Если выскочит окошко ”Script Error”, внимательно прочтите предупреждение. Там должна быть строчка, говорящая, что в такой-то строчке скрипта не всё в порядке и что собственно не в порядке. Например Synthax Error Line 13. Ищем тринадцатую строчку и смотрим, что же мы там не так сделали (в полоске внизу окна вы можете видеть номер строки, на которой находится курсор и через слэш общее количество строк в скрипте). В уведомлении на скрине написано, что мы пропустили кавычки. Исправляем. Сохраняем.


Ошибка в скрипте


Строка с ошибкой


Что ж, цветочки кончились, теперь пойдут ягодки :D.

Диалоги


Открываем меню Character -> Dialogue (кнопка OAGB 05.png). Появляется большое окно ”Dialogue”. Самое левое окошко разделено на несколько вкладок:

  • Topic - все-все темы для разговора, имеющиеся в игре. Отсортированы они Бог знает как и отсортировать их по-человечески не представляется возможным, поэтому новые и изменённые придётся выискивать вручную либо прокручиванием ползунка, либо нажатием на клавиатуре первой буквы топика. Отмечены они, как всегда, звёздочкой.
  • Voice - голоса. Разделено на несколько категорий. В какой что находится, догадаться не сложно. Категория, содержащая что-то новое, помечена звёздочкой. Сами реплики начинаются со звёздочки, поэтому искать их намного легче – нажать Shift + "*" и вы перескочите на первый изменённый файл.
  • Greeting – реплики, которые первыми появляются у неписей после того, как вы с ними заговорили (типа «Привет, Герой, я Орк. Чем могу помочь?»). Измененные категории и реплики отмечены аналогично Voice.
  • Persuasion – здесь содержатся реплики, которые вам говорит непись, когда вам удаётся или не удаётся убедить его. Для удобства также разделено на группы.
  • Journal – добавляемые в журнал записи. Отсортированы о алфавиту. Отмечены звёздочками в конце ID.

Под этим окошком мы видим выпадающее меню ”Filter For” со списком всех неписей в игре. Выбрав конкретного непися, на вкладках будет отображаться только то, что говорит именно он. Так переводить крайне не рекомендую, ибо не удобно это, запутаетесь.


Итак, выбираем одну тему и начинаем её переводить:

  • Вверху поле Info / Response. Нас интересует столбик Info (вмещает 512 символов). В нём отображаются все реплики, которые может сказать непись при разговоре на выбранную слева тему.
  • Выделяем нужную реплику и редактируем её в поле чуть ниже.
  • Чтобы правильно всё сделать, нам надо знать про ссылки. Ссылки в игре выделены синим и на них можно нажать - они являются ссылкой на топик. Чтобы топик появился в списке тем непися, нужно, чтобы ссылка работала корректно. Для этого во всех репликах она должна выглядеть один в один с названием темы. Например, есть в оригинале тема «лагерь Зайнаб», в реплике ссылка на данную тему должна выглядеть буква в букву, символ в символ, первое слово с маленькой буквы, второе – с большой. Вот так : «У нашего племени есть постоянное поселение – @лагерь Зайнаб#.»
  • В оригинальной игре ссылки помечены символом @ в начале ссылки и # в конце. В плагинах эти символы не отображаются. Если у вас возникают проблемы с отображением ссылок в игре и вы точно знаете, что перевели всё правильно, либо же вам сложно переводить, не видя слова-ссылки, пользуйтесь утилитой Mod Prepare (см. начало руководства).

В самом низу окна есть поле Result. Работает примерно так же, как и скрипты. В нём может ничего не быть, а может быть то, что мы должны перевести. А именно:

  • ShowMap, ChangeWeather, CenterOnCell, GetPCCell, AddTopic, MessageBox, Say и записи вида ZZ_BanditBoss" -> PositionCell -37149, -48007, 936, 0 "Bitter Coast Region" и всё такого типа, за которыми следует название ячейки или региона в кавычках. Как такое переводить, подробно описано в разделе «Скрипты».
  • Choice "Yes" 1 "No" 2 . В кавычках может быть что угодно, и именно это что угоно надо перевести, саму надпись choice не трогаем.

Теперь переводим само названия топика (не забываем, что ссылки и AddTopic должны с ним совпадать!).

Обратите внимание! Когда вы переименовываете топик, его пустой клон остаётся в плагине с пометкой DELETED. Если вы сохраните плагин только один раз, этот клон так и останется в нём. Чтобы от него избавиться (а это нужно сделать) сохраните плагин один раз, потом загрузите его в CS снова и снова сохраните. Это убьёт старый топик с пометкой DELETED. Конструктор не совершенен.

  • Voice. Здесь в поле Info / Response мы переводим то, что в игре будет субтитрами.
  • Greeting. Переводим Info / Response и Result и не забываем про ссылки.
  • Persuasion – здесь редко что-то бывает. Если что-то есть - переводим Info / Response.
  • Journal – здесь вместо имени ID записи, его не трогаем. Переводим опять-таки Info / Response.

Когда всё закончено, нажимаем «ОК».

Диалоговое окно

Затем тщательно проверяем перевод на предмет ошибок и опечаток, исправляем их, сохраняем плагин (кнопка OAGB 03.png). Также очень важно проверить, действительно ли все изменяемые плагином объекты изменены или же задеты случайно.

По работе в конструкторе, пожалуй, всё. Поздравляю!

Если мы переводим плагин, который каким-либо образом улучшает или изменяет стандартные объекты игры (например реплейсеры как Better Clothes, Authentic Signs или True Gems), то нет нужды заниматься копированием стандартного русского названия и заменой им английского. Всё можно сделать в два присеста.

Вот тут вспомним об утилитах Mod Info и Mod Text Merger. Устанавливаем их в папку с игрой.

*Этому приёму меня научил Argon, написавший замечательное руководство по быстрому переводу, большое ему за это спасибо!

Работа с Mod Info


  • Открываем Mod Info.
  • В левом верхнем углу открываем меню File -> Open File (кнопка MAA 047.PNG)
  • В поле "Тип файлов" выбираем "Master file *.esm" и выбираем Morrowind.esm (это если плагин затрагивает предметы оригинальной игры; если какого-то из дополнений, то выбираем его; если предметы и из оригинальной игры, и из дополнения(й), то проделываем описанную здесь операцию отдельно для каждого .esm).
  • Жмём "Открыть".
1
  • Далее открываем Files -> Find in master files (кнопка MAA 048.PNG).
  • В появившемся окошке ("Master Files") справа нажимаем "Add".
  • В меню "Тип файлов" выбираем "Plugin files (*.esp)" и выбираем наш плагин.
  • Жмём "Открыть", в окошке "Master Files" нажимаем "Ok".
2

После этого в окошке изменённые записи будут помечены тёмным.

  • Теперь открываем сверху меню Export -> Export For Translate, появится окошко Export Parameters.
  • Здесь ставим галочку возле "Changed" и жмём "Go".
  • В появившемся окне набираем имя файла и нажимаем "Сохранить".
  • Закрываем программу.
1
2
3

Названия всех стандартных изменённых предметов теперь сохранены в ...\Morrowind\Data Files в файле имя.txt. Вы можете открыть и посмотреть на них, но только ничего там не меняйте, если хотите перевести всё точь-в-точь, как оно переведено в оригинале.

Работа с Mod Text Merger


  • Открываем Mod Text Merger.
  • Нажимаем кнопку "Open", выбираем наш плагин и нажимаем "Открыть".
1
  • Теперь нажимаем кнопку "Replace texts" и выбираем наш текстовый документ.
  • Нажимаем "Открыть" и жмём "Go".
2

Ну вот и всё! В результате мы получаем копию нашего плагина, но с переведёнными стандартными объектами. Она сохраняется в \Morrowind\Data Files с названием _out.esp. Нам остаётся только его проверить на предмет ошибок и смело присвоить ему название плагина, с которого всё началось.

Обратите внимание: таким образом можно перевести не всё, например скрипты, текст книг, названия топиков, Result`ы в диалогах так не переводятся.

Чистка плагина


После окончания работы с конструктором и выявления всех случайно затронутых стандартных предметов, плагин нужно очистить от мусора. А это:

  • Задетые предметы etc.;
  • GMST – настройки игры, которые конструктор автоматически записывает в плагин. Не так много плагинов их изменяют, так что смело удаляйте их (если в ридми плагина ничего на их счёт не сказано). Причём эти настройки добавляются в плагин только если вы работаете с одним только Morrowind.esm, без аддонов. Если вы редактируете, а потом сохраняете плагин с Tribunal.esm и\или Bloodmoon.esm, то посторонние GMST записаны не будут. "Грязных" GMST в 98% случаев 72 штуки. Кстати зарубежное TES-сообщество называет их "evil GMSTs";
  • Неиспользуемые в моде объекты.
  • Задетые ячейки. Их можно опознать по нижней части окошка TESAme ("Сырые данные" в русской версии программы) - в столбце "Данные" будет всего где-то строчки 3 и на одной из них будет название локации (в 90% случаев это районы) и на другой какой-то символ, похожий на "КГ". Или один только символ с вертикальной палочкой, даже без названия локации. Если там что-то ещё, то обязательно проверьте эту ячейку в конструкторе. А если там ID каких-нибудь предметов, то ячейка наверняка не лишняя. Со временем вы сами научитесь это всё быстро распознавать, а первое время обязательно сверяйтесь с конструктором.
Перед тем, как что-либо удалять, внимательно проверьте в конструкторе и в игре, действительно ли это мусор!


Работа с TESAME


Итак, устанавливаем в папку с игрой программку TES Advanced Mod Editor (TESAME) и запускаем.

  • Вверху нажимаем «Моды -> Открыть»
  • Выбираем подлежащий редактированию плагин и жмём кнопку «Открыть».
  • Загружается наш плагин. Здесь видно всё, что он добавляет или изменяет.
  • Находим то, что, как мы выяснили ранее (а мы ведь не забыли выяснить, так ведь?), является мусором.
  • Выделяем файл или группу файлов, нажимаем пробел, а затем Delete на клавиатуре.
  • Дальше жмём «Моды -> Сохранить как» и сохраняем.
На всякий случай поверх готовой, но не вычищенной адаптации, сохранять не стоит! Во избежание ошибок и перевода всего плагина заново сначала сохраните отдельно, внимательно проверьте в конструкторе, а потом и в игре, не удалили ли мы что-то нужное.
  • Следите за тем, чтобы в имени окончательного файла не было приставки Copy_ и Clean_ (зависит от версии утилиты)!
Окно TESAME

Обратите внимание: среди объектов вам всё уже хорошо знакомо по конструктору, кроме Landscapes, Global, Textures, Lev Item, SSCR, Body Part, Sound и Path Grid. Мне ещё не встречались плагины, в которых эти объекты были добавлены по ошибке, поэтому если вам они встретятся, не трогайте их. Если вдруг всё-таки это мусор , бета-тестеры или программа TES PCD сообщат вам об этом. Также вы не сталкивались со Static, но будьте внимательны, как раз среди этих объектов очень часто бывает мусор.

Работа с TES PCD


Кроме конструктора в выявлении мусора нам поможет TES Plugin Conflict Detector (TES PCD). Устанавливаем его в папку с игрой и запускаем.

  • В левом верхнем углу окна открываем File -> Choose Plugins (OAGB 01.png).
  • Выбираем наш плагин и жмём "Открыть".
  • Далее вверху заходим в меню Operations -> Check Unclean. Если высветились какие-то объекты, то с уверенностью в 99% можно сказать, что это мусор.
  • Находим столбик с названием нашего плагина, выделяем в нём (и только в нём!) все объекты и нажимаем на клавиатуре Delete.
Удаление задетых объектов
  • Появится окошко, предлагающее сделать перед этим резервную копию данных, нажимаем "".

В том же меню Operations вы увидите команду Auto Delete Unclean. По идее с её помощью можно удалить весь мусор автоматом. Но я настоятельно не рекомендую этой опцией пользоваться, прога может поудлять что угодно, не только мусор, так что надёжнее всё сделать своими руками.

Всё, закрываем программу, мусор удалён.
Необходимые команды
Обратите внимание: естественно, вам захочется сделать как в любом подобном случае - сохранить изменения в файле через меню File -> Save Results и, как в любом другом случае, вы, скорее всего, замените им уже существующий файл. Так вот, НЕ ДЕЛАЙТЕ ЭТОГО! Ведь нам предлагается сохранить текстовые результаты работы, а не сам плагин! Тем самым мы пустим никс-гончей под хвост всю нашу работу. Поэтому после удаления мусора просто нажмите крестик в верхнем правом углу окна или File -> Exit.

Точно также можно выявить помеченные удалёнными объекты, что тоже является мусором. Для этого в меню Operations выберите Check Deleted.

Примечание: Что значит "помеченные удалёнными"?

Помните в самом начале моё предупреждение о том, что конструктором удалять ничего не стоит? Так вот, вместо того, чтобы удалить предмет из плагина, он его просто помечает удалённым, то есть, фактически, предмет из плагина никуда не девается и остаётся висеть ненужным мусором. Вот это оно и есть.

Упорядочивание файлов плагина


Плагины могут иметь при себе такие папки:

  • Icons – иконки предметов;
  • Meshes – модели;
  • Textures – текстуры;
  • BookArt – иллюстрации ко внутриигровым книгам;
  • Music – музыкальное сопровождение плагина;
  • Sound – звуки плагина;
  • Splash - загрузочные заставки (сплеши).

Текстуры, иконки и BookArt


Файлы текстур должны иметь расширение .dds или .tga и достаточное количество мип-уровней. Иконки и bookart тоже имеют этот формат, мип-уровни им не нужны вообще. Но мы не будем ими заниматься, нас интересуют текстуры. Чтобы посмотреть как дела у текстуры в формате dds, открываем её с помощью WTV (см. начало руководства).

В самом низу мы видим следующее:

  • Type – здесь должно быть только DDS.
  • Format – формат текстуры. Нас интересует 3 вида: DXT1, DXT3 и DXT5 (он используется нечасто).
  • В DXT1 сохраняются обычные текстуры, без прозрачности (она же альфа-канал) (в просмотрщике прозрачность выглядит как розовая область. Чтобы убедиться наверняка, используется ли в текстуре прозрачность, нажмите клавишу A (Ф) и если останется видна какая-то часть текстуры (чёрного или серого цвета), значит, это и есть прозрачность.
  • Текстуры же с прозрачностью – в DXT3, либо в DXT5.
  • DXT5 не стоит использовать всегда, потому что в нем сама картинка будет чуть менее качественной, чем в DXT3. Используется DXT5 при наличии на текстуре какой-то очень хитрой прозрачности. Проще всего жать в DXT3, а если какая-то текстура вдруг стала выглядеть криво - то пережать её оригинал в DXT5.

Подробней о форматах текстур здесь.

  • Size – размер текстуры.
  • MipMap – мип-маппинг. Мип-мапов (или мип-уровней) должно быть достаточное количество, иначе издалека предмет, на который наложена эта текстура, будет рябить и раздражать. Их должно быть по крайней мере столько, сколько степеней двойки в разрешении текстуры (поле Size), т.е. для 1024*1024 - 10 , для 512*512 - 9 и т.д.. Имеет формат x/x. Первое число – текстура, которую вы видите в данный момент, второе – их общее количество. Уровни различаются только размером, т.е. 1/9 больше, чем 2/9, которая в свою очередь больше, чем 3/9 и т.д. Не ищите все 9 штук в папке с текстурами - они все записаны в одном файле, который вы с помощью WTV и открываете.
Окно WTV


Работа с Adobe Photoshop


Просмотрите все имеющиеся в плагине текстуры. Если у какой-то из них недостаточно мип-уровней или она в .bmp, её нужно сконвертировать через Photoshop. Все инструкции относительно конвертирования одной текстуры или сразу большого количества находятся в текстовом документе внутри архива с ФШ, на который была дана ссылка в начале.

Я лично в ФШ работать не умею и использую его только для конвертирования текстур, поэтому он у меня старый, маленький, без наворотов, но мне и этого выше головы. А если вы владеете этой программой, пользуйтесь любой удобной для вас версией. Как совершать пакетную обработку и конвертировать отдельные текстуры вы наверняка знаете и так.

На заметку:
  • В текстурах формата .tga и .bmp прозрачности не видно, поэтому я рекомендую сначала сконвертировать их в DXT3, проверить их на предмет её наличия с помощью WTV и, если таковой не имеется, сконвертировать в DXT1.
  • DDS - формат, страдающий потерей качества, поэтому всё больше текстурщиков специально делает свои текстуры в TGA, например, Westly. Перед тем, как конвертировать из этого формата, посмотрите как текстура выглядит в игре. Если у неё недостаточно мип-уровней (она рябит при отдалении), сконвертируйте их, если же в игре они выглядят нормально - оставьте как есть.
  • Текстурам всякой одежды с цепями или сеточками (чулки в сеточку, мелкие кольчуги и т.п.) увеличение количества мип-уровней идёт только на вред - при отдалении от них они просто пропадают, растворяются на теле того, на кого надеты. Поэтому сначала обязательно сделайте резервную копию такой текстуры и если после конвертирования она стала себя некрасиво вести, верните обратно сохранённую копию без мип-уровней.

Архивы BSA


Для того, чтобы ничего не потерялось, а устанавливать и удалять плагин было легко, всё это надо запаковать в игровой архив – bsa (Bethesda Softworks Archive).

Обратите внимание: Sounds, Music, Fonts и Splash в bsa паковать нельзя - игра звуковые файлы, шрифты и загрузочные заставки из него использовать не будет!
  • Кладём папки Textures, Meshes, Icons и BookArt в отдельную папку с таким же названием, как и у файла плагина.
  • Распаковываем куда вам удобно содержимое архива с программой BSAPack.
  • Читаем инструкцию по интеграции в контекстное меню. Как упаковывать и запаковывать архивы описано там же.

Бывает так, что запаковав все нужные файлы в BSA, в игре мы наблюдаем жёлтые ромбы с восклицательным знаком в середине (не отображаются модели) или же абсолютно белые модели. Дело в том, что не все работают под привычным большинству Windows, предпочитая ему операционную систему Linux. Если вы обращали внимание, в Windows везде, где присутствует адрес (например C:\Documents and Settings\All Users\Рабочий стол) присутствуют слеши (наклонная палочка - "\"). Так вот в Linux тоже есть слеши, но они повёрнуты в другую сторону, т.е. "/". И когда автор прописывает созданной им модели текстуру, в пути могут присутствовать такие вот "обратные" слеши (на самом деле обратные слэши могут быть и у пользователей Windows, почему так - я до сих пор не знаю). Когда модели и текстуры лежат вне BSA, проблем не возникает. Но из BSA текстуры, в пути к которым прописаны обратные слеши, моделями не подхватываются (такая вот особенность), поэтому мы наблюдаем вышеозначенные глюки. Но в BSA запаковать всё равно надо. Вот тут-то нам и пригодится NifSkope.


Работа с NifSkope


С помощью NifSkope можно найти пути к текстурам и изменить слеши на те, что используются в Windows - "\". Для этого делаем следующее:

  • Открываем NifSkope.
  • Нажимаем "File->Load" или кнопку MAA 064.PNG.
  • Находим папку с моделями с обратными слешами и начинаем их по очереди загружать и исправлять такие слеши - "/" - на такие - "\".
  • Для этого нажимайте плюсики в поле "Block List", пока не увидите сиреневую ромашку, рядом с которой будет путь к текстуре, заканчивающийся расширением .dds, .tga или .bmp.
  • Если в пути слеши не присутствуют, ничего не трогаем, в том числе и расширение.
Окно NifScope
  • Если же обратный слеш присутствует, дважды кликните на путь к текстуре левой кнопкой мыши и замените обратный слеш на нормальный.
  • Так откройте все плюсики и удостоверьтесь, что ничего не пропустили.
  • После этого нажмите F3 и проверьте выпавшее меню на предмет путей к текстурам и обратных слешей.
  • Если таковые имеются, точно так же их исправьте.
  • Теперь просто закройте это окошко.
Окошко, появляющееся при нажатии F3
  • Нажмите сверху кнопку "File->Save As" (кнопка MAA 067.PNG) и замените исходный .nif исправленным (под тем же названием).
  • Так проверяем все имеющиеся в плагине модели и по окончании работы снова запаковываем всё в BSA.
  • Проверяем в Construction Set (если всё же вы что-то пропустили, то если вы попытаетесь взглянуть в окошке просмотра на нужный предмет, появится предупреждение о том, что для модели, например, Cuirass.nif не найдена текстура, например, bu/tex/cuirass.dds. Исправляем).

Итоги

MAA 068.gif

Теперь подведём итоги.

Мы имеем:

  • папку с названием плагина - «Something new» (без каких-либо приставок типа _rus и _1С - и так понятно, что скачанный с русского сайта плагин будет rus и сделан для 1С; нижние подчёркивания тоже не приветствуются)
  • внутри мы имеем ридми русский, ридми оригинальный, скриншоты (а вы как думали! Для наглядности, причём как можно красивее. Слышали что-нибудь про маркетинг?). Причём даже если плагин геймплейный - щёлкните в игре хоть что-нибудь хоть как-нибудь связанное с плагином и вставьте в ридми - так пользователю будет не так нудно читать сплошной текст, а если даже щелкнуть нечего (у вас какой-нибудь плагин со звуками, к примеру), найдите в интернете красивую картинку по теме.
  • папку Data Files, в ней:
  • Something new.esp (без каких-либо приставок типа _rus, _1С и нижних подчёркиваний!)
  • Something new.bsa (без каких-либо приставок типа _rus, _1С и нижних подчёркиваний!)
  • папки Sound, Music, Fonts и Splash (если таковые имеются в плагине, естественно).

Если вы ориентируетесь на сайт FullRest, то вместо обычного ридми нужно написать хороший "фирменный" (подробней здесь).


Мы всё проверили и у нас всё работает, прекрасно. Повторяю, мы, в смысле ВЫ, проверили - не выпускайте в свет нерабочие адаптации с багами - они никому не нужны. Теперь пакуем всё в архив (желательно в 7zip, свежую версию архиватора всегда можно найти здесь).


Ура! Можно смело выкладывать адаптацию в базе FullRest.ru.



  • Автор: Menorra.
  • Вы не можете распространять текст данного руководства без разрешения автора.
  • Выполнено для FullRest-Team.