Modding:Знакомство с GIMP и начала текстурирования для TES

Материал из Tiarum
Перейти к: навигация, поиск
GIMP: ЗНАКОМСТВО И НАЧАЛА ТЕКСТУРИРОВАНИЯ
45px-Scroll.png

автор: Siegrun
редактирование: Garin
ccылка на оригинал: GIMP: знакомство и начала текстурирования
ссылка на сайт: TesAll


Gimp.png GIMP: знакомство и начала текстурирования

Автор: Siegrun

При выборе редактора для двухмерных работ чаще всего пользователи останавливаются на Фотошопе (Adobe PhotoShop). Однако у этого прекрасного редактора есть не менее замечательный конкурент - программа, уверенно завоевывающая пользователей благодаря своей открытости и доступности в сочетании с большим набором возможностей и свойств, некоторые из которых не уступают продукту Adobe. Это GIMP.

Посетив официальный сайт разработчиков, вы получите исчерпывающее представление о программе, а мы сосредоточимся на более близких нам вещах.

Громадное преимущество программы - это ее вес. Вместе с портированными из Linux библиотеками (GTK) вес этой проги составляет 13МВ (развернутой - 32МВ). Это графический пакет, который любой человек может использовать в любую минуту, с полным функционалом и занимающий очень мало места.

Давайте бегло пробежимся по возможностям программы:

  • + частичная поддержка векторной графики и массы форматов файлов (включая например, ico - формат иконок Windows, и конечно - dds, так же, как и фотошоп - через плагин)
  • + работа со слоями, каналами, масками, контурами

Полный набор всех действий:

  • + инструменты для рисования, коллажа
  • + обработка рисунков и фото - скрипты, фильтры, трансформирование
  • + работа с текстурами
  • + предустановленные скрипты и градиенты - очень хорошего качества, гораздо лучше, чем дефолтные градиенты фотошопа
  • + более низкий размер файлов при сохранении в форматах для веба
  • + при помощи плагина поддерживает кисти и фильтры фотошопа - чтобы пользователи не отказывались от привычных инструментов
  • + Благодаря большому количеству плагинов и скриптов может применяться для редактирования векторной графики, создания анимации и т.д.

Однако у программы есть и свои минусы. Они фактически не касаются тех функций которые используются для игр (текстурирование), но делают ее неудобной для полиграфии:

  • - Прежде всего это отсутствие поддержки цветовых профилей, CMYK (все таки реализована с внешним плагином), плашечные цвета, CIE. Поскольку при изготовлении текстур я пользуюсь RGB, мне это никак не мешало.
  • - Работа со шрифтами. Нет, все шрифты у вас будут работать, но сам процесс ввода и редактирования неудобен.
  • - Только 8 бит на канал. Увы. И отсутствие поддержки концепции Гамма - то есть выходной результат по модели sRGB с нелинейной Gamma.
  • - Не поддерживает эффекты слоя.

Почему же все-таки, невзирая на эти недостатки и присутствие фотошопа, я все-таки пользуюсь этой программой?

Проведем несколько экспериментов, которые наглядно иллюстрируют специфические особенности программы.

Рисуем скругленный прямоугольник.


Начнем с простой вещи, которую вы не обойдете при рисовании. Особенно для веб, но и так тоже. Это скругленный прямоугольник. Я сделаю его в Adobe Photoshop CS2.

Открываю редактор, создаю новый файл и собираюсь там сделать скругленный прямоугольник...эм... да. Векторная фигура. Оно мне не надо, но придется. Делаем.

Рваные края этой фигурки (радиус 3 п) наводят на грустные мысли. И вообще-то мне бы хотелось просто линию. Черную. Но для этого мне бы стоило сделать фигуру нужного цвета, растрировать, выполнить обводку в свойствах слоя - черного цвета, и... обводка образует не линию, а такую же фигуру со сплошной заливкой - только побольше. Сохранять ее в слой, дабы получить линию - бесполезно. В общем, это совсем не то.

Запустим GIMP. Создадим новый файл и далее сделаем прямоугольник. Ту самую линию. Берем инструмент "прямоугольное выделение" и выделим на фоне прямоугольник нужного размера. Далее идем: Выделение -> Скругленный прямоугольник и выберем радиус (3 п, как и ранее) - наше выделение скруглилось, оставаясь просто выделением. Теперь Правка -> Обвести выделенное - выбираем цвет и толщину линии, а также, может, шаблон (неоднородная, с шумом, из текстуры) и жмем Обвести. Затем снимаем выделение. Наш прямоугольник готов. Ничего лишнего, только контур, одна линия заданной толщины. Разница очевидна.

Быстрое трансформирование


Едем дальше - быстрое трансформирование. Инструменты трансформации в GIMP на виду и позволяют быстро вращать, масштабировать и отражать вклеенное, не отвлекаясь на выпадающие меню. Что не может не радовать.

Текстуры.


Ну и, наконец, то, что мне нужно в гимпе, когда я работаю с ТЕС. Моделирование требует текстур,а текстуры требуют разверток на сложных объектах и бесшовности на простых.

Инструмент по умолчанию для создания бесшовных текстур есть в обоих программах. Создадим для сравнения паттерны в Photoshop и GIMPе. Используем для этого сложный объект:

Original 01.jpg

Откроем изображение в гимпе, идем в Фильтры -> Карта -> Без швов - и получаем готовую текстуру :) Очень даже симпатично. Я ничего не настраивала, и этот дефолтный инструмент не умеет заполнять страницу текстурой. Но полученный результат очень даже устраивает.

Gimp 02.jpg

Поместим ту же картинку в фотошоп. Выберем Фильтры -> Паттерн. Откроем и применим дефолтные установки...упс...ОМГ.

Photoshop 03.jpg

А где же киса? Думаю, можно не продолжать. Один человек в ответ на вопрос "почему так?", сказал: уметь нужно. Однако повторить результата не смог. Я говорю: просто сделайте это в GIMP одной кнопкой.

Давайте сделаем текстуру ржавого металла в GIMP.


Найдем подходящую фотографию или картинку. Тем лучше тому, у кого есть фотоаппарат - его текстуры будут оригинальными. Откройте картинку в гимпе и запустите процесс изготовления текстуры. Все, ваша текстура ржавого металла готова. Сохраните ее в любой поддерживаемый Морровиндом формат и пользуйтесь. Также вы можете нарисовать любую картинку для текстурной развертки точно так, как сделали бы это в фотошопе. К счастью, для гимпа полно мануалов и ресурсов.

Конвертируем нашу текстуру в dds. Не забудьте, что у текстур для игр должны быть стандартные размеры, кратные степени двойки, например, 8, 64, 128 и так далее. Давайте ретекстурим какую нибудь модель. Я взяла шлем из какого то плагина. Возьмите и вы что нибудь подходящее.

Откройте модель нифскопом. Слева дерево свойств. Найдите там текстуры, используемые на модели. Возьмите нашу dds, присвойте ей такое же имя, как на текстуре, которую хотите заменить, и поместите ее в нужную папку Морровинда.

На вопрос о замене ответьте "да". Теперь смотрите на шлем: его рога приобрели характерный ржавый тон.

До ретекстуринга...
После ретекстуринга...

Если бы я хотела наложить узор, то мне необходимо было бы открыть 3D-редактор (я пользуюсь Блендером - это быстрее всего) и перелинковать текстуры, назначив им новые координаты на развертке.

Но сейчас у нас такой задачи нет и мы сделали ретекстуринг, используя имя уже назначенной текстуры.

РЕЗЮМЕ.


  • Пользуясь всего лишь двумя этими небольшими программами - GIMP и NifSkope, вы можете сделать быстрый ретекстуринг простых, не требующих особой красоты, объектов.
  • Более сложные модели, с большим количеством полигонов, вы можете перетекстурировать, если используете совместно с GIMP одну из программ трехмерного моделирования, например, Blender.
  • Этот тандем - GIMP и Blender 3D, образуют компактную, но с огромными возможностями лабораторию для модостроения в мире TES.