Fallout3:Руководство по созданию мира

Материал из Tiarum
Перейти к: навигация, поиск
Fallout 3: Руководство по созданию мира
45px-Scroll.png
автор: BloodBear
редактор: IgorLutiy (Igor_Ra)
вики-редакция: Garin
ccылка на оригинал: Туториал по созданию мира в Fallout 3 (419,4 KB)
дата оригинала: 23.01.2010г.
версия оригинала: 1.0
версия вики: 1.01
Авторская Эта страница защищена авторскими правами..
Не редактируйте его без предварительного согласования с автором! Свои изменения и дополнения вы можете предложить непосредственно автору, либо на Форуме, либо на странице Обсуждения


Fallout 3: Руководство по созданию мира


Вступление

В этой статье мы обсудим создание нового мира, кроме того, будет подробно рассмотрен редактор ландшафтов и редактор высот.

Когда вы дойдете до конца этой статьи, у вас будет свой остров посреди океана. В дальнейшем вы сможете самостоятельно заселить этот остров различными персонажами.

ВНИМАНИЕ: Данная статья предназначена для людей, у которых уже имеются базовые навыки работы с редактором GECK.

Что нам потребуется

  1. GECK (Garden of Eden Creation Kit) - собственно, сам редактор игры.
  2. G.E.C.K. update 1.1 to 1.5 - обновление до версии 1.5.
  3. Adobe Photoshop - 2D-редактор для работы с текстурами dds и другими графическими файлами.
  4. Мозг.

Начало работы

Прежде чем мы начнём работать с G.E.C.K., мы должны продумать, что хотим создать, и продумать историю нашего нового мира.

Я создам остров, который остался нетронутым войной и радиацией.

  • Запустите G.E.C.K.
  • В строке меню переходим File > Data.
  • В открывшемся диалоговом окне отмечаем мастер файл Fallout3.esm и файл Russian.esp (это русификатор игры). После этого подождите пару минут, пока загрузятся данные игры. В случае вылета ошибок один раз нажмите «Отмена» и ошибки больше не вылезут.
  • Далее сохраните плагин и назовите его MyWorld.
  • Теперь выходим из редактора.
  • Запустим редактор повторно, но теперь отметим наш плагин как активный.
  • Для этого выделяем наш плагин и жмём кнопку Set as Active File.
40px-AttentionPic.png ВНИМАНИЕ: Чаще сохраняйтесь, так как G.E.C.K. достаточно часто вылетает.

Создание игрового пространства

  • Зайдите в строке меню: World > World Spaces.
  • Кликните правой кнопкой на списке слева и выберите в открывшемся контекстном меню пункт New (Новый).
  • Вам нужно будет ввести название нового игрового пространства, поэтому введите: MyWorld. Оно не будет отображаться в игре, так что вы можете назвать его как угодно, но лучше называть его так, чтобы его было легче находить в списке миров.

Итак, игровое пространство создано. Рассмотрим параметры, которые мы можем настроить:

  • Name (Название): Данное название локации будет отображаться в игре. Вводим: "Мой мир".
  • Parent Worldspace (Родительское пространство): нужно указать, если пространство является частью другого пространства (например, пространство города в пространстве Пустоши). Не трогаем.
  • Climate (Климат): какая погода будет в данном игровом пространстве. Выберем WastelandClimate.
  • Water (Вода) - Вода, которая будет в нашем мире. Выбираем d1PurifiedWater0r30h (Чистая вода).
  • Default Water Height (Уровень воды по умолчанию): Выставляем 10500.
40px-AttentionPic.png ВНИМАНИЕ: Обязательно выставляйте параметр 10500, в противном случае могут возникнуть проблемы с отображением воды, текстур.
  • LOD Water Height (Уровень воды вдали): Выставляем 10500.
  • LOD Water Type (Тип воды, который будет вдали): Выбираем d1PurifiedWater0r30h (Чистая вода).
  • Default Land Height (Уровень земли): Выставляем в диапазоне от 6000 до 14000. Мы выберем 10100.
  • Image Space – настройки HDR. Выбираем: DefaultImageSpaceExterior.
  • Map Image (Изображение карты): Собственно, сама карта. Вот путь к стандартной карте: interface\worldmap\wasteland_1024_no_map.dds. Создавайте карту в Фотошопе и сохраняйте в формат dds, только после этого вы сможете прикрепить её к своему миру.
  • В Usable Dimensions выставляем такие параметры:

F3-WCT-001.jpg

  • В Cell Coordinates – Координаты ячейки, выставляем такие параметры:

F3-WCT-002.jpg

  • Small World – Отмечаем, если делаем небольшой мир. Для экономии ресурсов игры. Отметим.
  • Can’t travel from here – Если отметить, быстро путешествовать отсюда будет нельзя. Отметим.
  • Can’t wait – Если отметить, ждать в этом мире не сможете. Не трогаем.
  • No LOD water – Вода вдали не будет отображаться. Не трогаем.
  • Music – Выбираем музыку, которая будет проигрываться в мире. Не трогаем.

Это основные параметры мира.

Далее загрузим наш мир в окне просмотра (Render Window).

  • Для этого в окне Cell View из выпадающего списка World Space выберите наш мир - MyWorld. После этого он загрузится в окне просмотра.
  • Вот мы и создали основу для нашего мира. Приступим к редактированию поверхности.

Работа с редактором ландшафтов

Чтобы включить редактор ландшафта, в строке меню переходим World -> Landscape Editing (или жмем горячую клавишу H – при активном окне просмотра).

F3-WCT-003.jpg

Давайте подробнее рассмотрим этот редактор.

  • Height (высота):
  • Edit Radius – размер курсора вашего инструмента (допустимые значения от 1 до 15).
  • Edit Fallout % – не используется.
  • Flatten Vertices – сглаживание земли (равняет землю по последней выставленной высоте).
  • Soften Vertices – смягчение земли (делает склоны более пологими).
  • Show Edit Radius – включает/выключает отображение курсора.
  • Texture (текстуры):
  • Texture List – список всех текстур.
  • Selected Texture – предварительный просмотр выбранной текстуры.
  • Max Opacity – уровень прозрачности текстуры, которая накладывается.
  • Vertex Color (цвет вершин):
  • Edit colors – если отмечено, то мы можем использовать левую и правую клавиши мыши для нанесения на поверхность цвета.
  • RGB (слева) – цвет, который будет на левой кнопке мыши.
  • RGB (справа) – цвет, который будет на правой кнопке мыши.
  • Select color – две кнопки, которые позволяют выбрать цвет.

Создадим небольшой островок в нашем мире. Для этого в окне просмотра поднимем нашу землю. Зажимаем левую кнопку мыши и двигаем мышь вверх и вниз. Результат должен быть приблизительно такой:

F3-WCT-004.jpg

40px-AttentionPic.png Примечание: для нанесения на поверхность текстур используйте правую клавишу мыши.

Теперь перейдём к редактору высот. Но в дальнейшем нам придется опять вернуться в редактор ландшафтов, для детальной настройки острова.

Работа с редактором карты высот

  • Зайдите в редактор карты высот: World -> Heightmap Editor или кликните на кнопку с изображением глобуса GECK 10 - IconHeightmap.jpeg на панели инструментов.
  • Когда вас спросят, какое игровое пространство вы хотите изменить, выберите наш мир – MyWorld. Откроется окно редактора высот.
40px-AttentionPic.png ВНИМАНИЕ: Сохраняйтесь перед его использованием, чтобы предотвратить неприятности.

Редактор высот имеет такие функции:

  • редактирование ландшафта,
  • генерация ландшафта,
  • генерация упрощённых моделей далеко расположенных объектов ландшафта.

Рассмотрим его подробней.

Основные инструменты редактора, которые нам пригодятся:

  • Brush Control (настройки кисти) - Используются для установки параметров кисти, с помощью которой и выполняются все работы в редакторе карты высот. Тут можно изменить размер, интенсивность и мягкость кисти (Falloff).
  • F3-WCT-005.jpg - Gridlines (линии сетки) - Отображает линии сетки. Удобно для ограничения размера плагина. Включается так: View -> Gridlines.
  • F3-WCT-006.jpg - Marquee/lasso (шатёр/лассо) - Используйте его, чтобы исключить возможность внесения изменений вне выбранной области.
  • F3-WCT-007.jpg - Raise Land (Высоты) - Выглядит, как иконка с изображением горы и стрелки, направленной вверх. Поднимает землю, используя параметры, выбранные с помошью "Brush Control".
  • F3-WCT-008.jpg - Lower Land (Низины) - Выглядит, как иконка с рекой в долине и стрелкой, направленной вниз. Опускает землю, используя параметры "Brush Control".
  • F3-WCT-009.jpg - Brush (Кисть) - Выглядит, как кисть. Используется для "рисования" цветом, выбранным с помощью пипетки (Dropper).
  • F3-WCT-010.jpg - Dropper (Пипетка) - Позволяет выбрать высоту поверхности на карте, кликнув на нужный пиксель. Выберите кисть, чтобы затем установить выбранную высоту.
F3-WCT-011.jpg

На карте видна область, которая отличается по цвету от остальных. Это область, на которой земля находится выше уровня воды. Это то место, в котором мы сделали немного поднятый ландшафт.

  • Включите линии сетки и, используя "лассо", выделите область, примерно пять клеток. Эта область станет поверхностью земли.
  • Теперь выберите "пипетку" и кликните на земле, которую мы сдвинули. Квадрат справа от иконки пипетки должен поменять цвет на тот, которым отображается наша земля.
  • Выберите кисть и нарисуйте остров.
  • Теперь вокруг нашего острова понизьте уровень земли с помощью инструмента Lower Land.
  • Должно получиться что-то подобное:

F3-WCT-012.jpg

  • Размер кисти вы можете поменять в настройках кисти.
  • Процесс создания очень долгий, но, в конечном итоге, после нескольких часов работы у вас может получиться очень даже привлекательный островок.
  • Вернёмся к редактору ландшафтов и подкорректируем остров. У меня в конечном итоге получился вот такой островок:

F3-WCT-013.jpg

Нанесём текстуры. Для этого:

  • Выбираем в списке текстуры и с помощью правой кнопки мыши красим наш остров.
  • Выберите из списка: LGrassGreenSuburbs и покрасьте весь остров.
  • У вас получится такая картина:

F3-WCT-014.jpg

  • С помощью такого же способа покрасьте весь остров разными текстурами.

Добавление своих текстур

Для начала нам нужно подготовить свою текстуру. Она должна быть размером 1024 на 1024, в формате dds.

  • Для работы с этим форматом, скачайте и установите на Фотошоп плагин для работы с DDS: NVIDIA Photoshop Plug-In.

Кроме самой текстуры, нам еще понадобится карта нормалей.

  • О создании карты нормалей вы можете почитать в этом руководстве: "Туториал по ретекстурированию" от Imperator3.
  • Сама текстура и карта нормалей должны находиться в этой папке: Fallout 3\Data\textures\landscape
  • Теперь, когда у нас есть текстура и карта нормалей, в Окне объектов идём по пути: Miscellaneous -> Texture Set.
  • В списке справа жмём правую клавишу мыши и в появившемся контекстном меню выбираем New.
  • Откроется окно, в котором вводим:
  • ID: MyTextures.
  • В Diffuse выбираем свою текстуру:
F3-WCT-015.jpg
  • В Normal/Gloss выбираем свою карту нормалей:
F3-WCT-016.jpg
  • Жмём ОК.
  • Далее переходим к Miscellaneous -> Land Textures.
  • В списке жмём правую клавишу мыши и в появившемся контекстном меню выбираем New.
  • Откроется окно, в котором вводим такие данные:
  • В ID пишем идентификатор текстуры, например, MyTextura.
  • В Texture Set выбираем до этого созданную текстуру MyTextures
  • В Material Type выбираем тип поверхности. Выбираем SAND – песок.

F3-WCT-017.jpg

  • Жмём ОК. Всё, теперь эта текстура есть в списке редактора ландшафта.
  • Все текстуры ландшафта хранятся в этой папке: Fallout 3\Data\textures\landscape

Советы по созданию мира и прочие мелочи

Последние штрихи – и вот, у меня получился такой остров:

F3-WCT-018.jpg

А вот как он выглядит в игре:

F3-WCT-019.jpg

Нам осталось сделать путь, по которому главный герой будет попадать на этот остров. Рассмотрим два возможных варианта.

Первый вариант такой:


  • Создадим новую дверь. Назовём её Lodka.
  • Выбираем модель двери. Выберите лодку, вот она: Fallout 3\Data\meshes\vehicles\boat03b
  • Размещаем эту лодку в нашем мире.
  • Щелкаем на ней два раза, откроется диалоговое окно, в котором вводим данные: REF Id: Lodka1REF
  • Отметим галочкой Persistent References.
  • Разместим эту же лодку (дверь в виде лодки) где-то на Пустошах.
  • Щёлкаем два раза, откроется окно, в которое вводим такие данные: REF Id: Lodka2REF
  • Снова отметим галочкой Persistent References.
  • Возвращаемся обратно в наш мир.
  • Выбираем нашу лодку, в закладке Teleport выбираем локацию на Пустошах, где расположена вторая лодка. И тут уже выбираем лодку.

Существует и другой способ попасть в новый мир.


Этот способ получится реализовать с помощью активаторов и скриптов:

  • Идём по такому пути: World Object > Activator.
  • Жмём в списке справа правую клавишу мыши и в появившемся меню выбираем New.
  • Откроется окно, в котором настроим такие параметры:
  • В ID пишем: Lodka1.
  • Name: Лодка
  • Model: Fallout 3\Data\meshes\boat03b
  • Script: Пока не трогаем.
  • Далее создадим ещё один активатор и выбираем такие параметры:
  • В ID пишем: Lodka2.
  • Name: Лодка
  • Model: Fallout 3\Data\meshes\boat03b
  • Script: Пока не трогаем.
  • Теперь поместим первую лодку (Lodka1) на пустошах.
  • Щёлкаем по ней два раза, откроется окно настроек копии объекта (Reference), в котором вводим такие данные: Ref ID: Lodka1REF
  • Отмечаем галочкой Persistent References.
  • Поместим вторую лодку (Lodka2) в нашем мире.
  • Щёлкаем два раза, откроется окно, в котором вводим такие данные: Ref ID: Lodka2REF
  • Отмечаем галочкой Persistent References.
  • Ну а теперь повесим скрипты на активаторы:
  • Первый скрипт вешаем на Lodka1:
scn Lodka1Script
Begin OnActivate
    Player.Moveto Lodka2REF
end 
  • Второй скрипт вешаем на Lodka2:
scn Lodka2Script
Begin OnActivate
    Player.Moveto Lodka1REF
end

Таким образом, если мы подойдем в игре к первой лодке и активируем ее, то перенесемся ко второй лодке, которая находится в созданном нами мире. Теперь вы можете свободно заселять остров и размещать на нём города, леса или пустоши.

Эпилог

Вот, собственно, и закончен туториал по созданию нового мира.

В результате я получил вот такой остров посреди океана:

F3-WCT-020.jpg

Теперь, после прочтения этой статьи, вы сможете создать такой же остров на территории пустошей. В этом вам тоже поможет редактор ландшафтов.


©Автор: BloodBear


  • Меня можно найти на форуме www.modder.3bb.ru (под ником BloodBear).
  • Правка и дополнения: IgorLutiy (Igor_Ra)
  • Все права на данную статью принадлежат авторам, то есть нам. Если вы желаете разместить этот материал где-либо, свяжитесь, пожалуйста, с нами!